Naze32 setup challenge

Ok, maybe someone here can shed some light on my issue.
Ever since i’ve re-calibrated my ESC my quad has been unflyable.
In Cleanflight I’ve been noticing a strange lag in the roll axes. See video.
(Only happens with roll, the pitch and yaw are rock steady)
I can’t seem to hover. When I apply power gradually the motors spike and the quad shoots up towards the point I have to cut power completely to save it.
Don’t know if these two are related.

Secondly I tried flashed it with latest firmware blue light comes on, it recognizes it but I have a green light that continues to blink. I’ve tried to restore stock config from supplier, but also to no avail. Did Acc calibration and Mag calibration. Did ESC calibration. Green light keeps blinking, see vid. I’ve Restored the supplier stock Configuration file as supplied here (scroll all the way down) Naze32_supplier_Config

Additionally motors 1 and 4 start spinning around throttle 1177 while motors 2 and 3 start at around 1186. Does the same thing after countless times of esc calibration.

Any and all help is welcome.

Regards,

Maybe a bad gyro, have you tried another flight controller?

Green light issue may be autotune turned on.

what mode are you flying?

What ESC’s do you use? With OneShot enabled?

Ok, so i’ll try to reply all in 1 block.

I’m flying a pre-build ordered from the UK. The build-List can be found HERE

  • When I calibrate ESC’s OneShot is not enabled.
  • I fly in Horizon mode. I know pro’s fly in Rate, but i’m not quite there yet. And right now i’m Only flying LOS as I have no FPV-backpack.
  • I don’t have any other parts (FC, or ESC) to swap and troubleshoot.

When I got the quad, it was flying rock-solid though, even after crashes. I was only getting some motor vibrations and issues with motor 1 and 4 firing before 2 and 3. That’s why I tried re-calibrating ESC, and it all went south from there.