Geen horizon en angle mode in cleanflight?

Op m’n turnigy 9xr heb ik netjes een 3 position switch genaakt met behulp van YouTube filmpjes.
In cleanflight staan arm, horizon en angle mode bij elke positie van de switch op groen.
Als ik de quad wil testen in de tuin krijg ik alleen de “arm” mode op m’n 9xr. De horizon en Angle mode doen het op de quad dus niet, terwijl elke modus in CF apart van elkaar op groen staan.
Ik wil heel graag kijken of ik in horizon mode kan gaan vliegen omdat de quad absoluut niet stabiel opstijgt. Ding valt na opstijgen na 30 centimeter op zijn zijkant.
Iemand enig idee?

Ik weet niet precies wat je bedoelt met ‘op m’n 9xr’, maar je kunt in ieder geval zien of je naze (ik ga er even vanuit dat je een naze32 hebt) in horizon of angle mode staat. Er zou dan een rood ledje (de buitenste van de 3) moeten branden. In ‘arm’ mode brand die rode led niet. Dus het is simpel na te gaan of je quad in arm of horizon/angle mode staat.

Ja. Het gaat om een Naze32. Met “mijn 9xr” bedoel ik dat ik een 3 position switch heb ingesteld in de mixer.
Het probleem is eigenlijk dat in cleanflight de 3 modussen allemaal afzonderlijk groen branden op de pc. Alleen hij vliegt alleen maar in acro. De 3 position switch werkt dus niet op de quad. En dat vliegen in acro gaat niet helemaal goed :thumbdown:

ik zit toevallig nu zelf ook te prutsen in cleanflight, en heb even gekeken. Met batterij aangesloten brand enkel de blauwe led. Als ik mijn switch in horizon of angle mode zet, gaat de rode led branden. Bij mij brand geen groene led als ik de batterij aangesloten heb. Als ik de batterij loskoppel, begint de groene led te knipperen.

[edit] We praten langs elkaar heen :slight_smile: Jij praat over ‘groen’ in de ‘modes’ tab in cleanflight. Ik bedoelde de groene leds op de FC. Check om te beginnen eerst even of je rode led gaat branden op je FC. Dan kan rustig stap voor stap alles uitgesloten worden. Als die led niet brand, zit er misschien iets mis in je setup in je 9xr.

Daar moet het haast wel zitten dan. De nodes tabs in cleanflight geven inderdaad groen ligt. De quad reageert alleen met arm mode en daar zie ik ook alleen de groene lichtjes branden op de naze32.
Op m’n 9xr heb ik in de mixer op channel 5 nu 3 kanalen gemaakt. Id0,id1 en id2. Zal eens ff gaan kloten met de waardes dan ofzo…

Ik heb een 9xr Pro en heb de 3 position switch ook ingesteld. Hier een foto met mijn instellingen voor de 3 position switch (ch6)

waarom heb jij channel 5 en 7 zo ingesteld? Heb je PPM ingesteld? Channel 6 heb ik precies zo ingesteld maar da op kanaal 5.

Dat zijn andere switches op mijn 9xr pro. Je zou in principe alleen naar Channel 5 te kijken, als je de waardes precies hetzelfde hebt dan zou het probleem in cleanflight liggen.

M’n quad trekt bij opstijgen direct na 30cm naar rechtes en valt op z’n kop. Heb de esc en motor al vervangen maar niets helpt. Heb jij enig idee? Zoek me rot naar mensen met een 9XR met hetzelfde probleem. Jij enig idee? Iets met trimmen op je 9XR ofzo?

Ben zelf ook best nieuw in de quad wereld, maar ik heb niet veel bijzonders gedaan met mijn 9XR. Heb je goed gecalibreert in CF? Heb je alle props goed zitten? Heb hier een aantal foto’s van wat instellingen die ik heb veranderd/ingesteld. Heb op het moment geen Naze32 bij de hand waar ik de instellingen van kan laten zien, maar ben recent overgestapt naar BetaFlight en heb niks bijzonders hoeven te veranderen.



(Niet beste foto’s)

Dus je hebt je zender alleen hoeven te configureren in cleanflight? Dus alleen zorgen dat je yaw enzo op 1500 staan? Of moet ik ook alle pids gaan instellen? Heb nieuwe props geprobeerd maar blijf met zelfde euvel zitten. Vandaar dat ik horizon mode wilde proberen.

Nee, ik bedoelde eigenlijk dat ik verder niks hoefde te veranderen in cleanflight (zo ver ik mij herinner).

ook geen trim dingen op je zender?

Nope

hahahaha sorry voor spammen. Denk alles opnieuw ff instellen dan maar.

Je wilt niet weten hoe lang het mij de eerste keer heeft geduurt om alles werkent te krijgen, en hoe vaak ik opnieuw ben begonnen. :smiley: Het zou het allemaal waard zijn!

geduld begint wel een beetje op te raken zo. :silent:

Werkt alles goed in de Modes tab in Cleanflight? Je ziet het gele streepje verplaatsen bij het bewegen van de switch?

Welke PID controller gebruik je in Cleanflight?
Als alles binnen Cleanflight normaal werkt, dan zou je bijna denken dat je PID’s totaal niet goed staan.

Heb je enige ervaring met vliegen? Of is dit je eerste keer? Misschien iemand in de buurt die wel kan vliegen?

Vannacht alles opnieuw geïnstalleerd op de Naze en CF. Heb de setting van Boris overgenomen en ingeladen in cleanflight. Gebruik cleanflight v0.66 nu. Probleem voorlopig opgelost. Heb “arm” nu niet geselecteerd. Alleen horizon en angle op m’n 3 switch. Las net ergens dat de “arm” modus automatisch al staat ingesteld. Nu heb ik in zowel cleanflight als op de Naze groene lichtjes branden als ik schakel tussen de flight modussen. Heb quad al tijd klaar maar kan nog niks mee ivm overtrekken naar rechts en op z’n kop landen.

Met alles bedoel je daar ook de PID settings? Als je dat namelijk gedaan hebt is dat zeer waarschijnlijk de reden waarom hij flipt. Je zou eens een andere PID controller kunnen proberen met de stock settings om te kijken of dat het probleem is.