Frsky firmware upgrade werkt niet

wat doe ik fout , probeer de Frsky een firmware upgrade te geven zodat ik van dat EU gedoe af bent maar krijg steeds deze fout code over een USB device die niet DFU capable is?

iemand hier ervaring mee?


Ik had ook problemen met firmware updaten. Uiteindelijk lukte het me volgends de manier in deze thread: link.

Staat duidelijk wat je moet downloaden en wat je moet doen.

Deze instructie heb ik gevolgd toen ik van de de nieuwe LBT versie af wilde. Ik weet niet of het overslaan van deze stap zou leiden tot de melding die jij krijgt.

“At this time, a working STM 32 Bootloader driver is the only way Windows computers will update OpenTX to v2.x and above the first time from either an earlier version of OpenTX [pre-V2.0)or another firmware package such as FrSky’s OEM version.”

dank alvast, zal van de week als ik wat meer tijd hebt hetgeen uitproberen :thumbup:

nou schiet mij maar lek, alles tot in de treuren uitgevoerd en weet ik wat nog meer maar er wordt gewoon niets geflashed of wat dan ook…
iemand nog een oplossing?

krijg nu steeds de melding: new firmware is not compatible with the one currently installed

Zo te horen kies je de verkeerde radio ? Je moet eerst de juiste radio kiezen, begin eens bij 5.20 in deze video. Die melding krijg je omdat je nog niet de juiste radio hebt gekozen en direct op update firmware drukt :-). Dus settings >> radiotype >> en kies daar je radio >Taranis plus.

Dat filmpje had ik al als eerste gezien ja toen ik eraan begon, het is helaas niet het probleem ondanks die wel dezelfde fout code geeft. Had zelfs nog allebij de taranis uitvoeringen gekozen maar mocht helaas niet baten.
Het verschil wat ik wel hebt in verhouding met het filmpje is dat ik nog EU aan of uit kan vinken wat met het protocol te maken heeft maar ook wat ik daarbij kiest maakt niet uit

Vaag zeg…misschien staat hier nog wat nuttigs bij ?

https://asaplol.wordpress.com/2015/03/21/updating-taranis-x9d-plus-firmware/

I just purchased Taranis Plus with eu firmware and had the same issue, could not flash open-tx firmware. I could not even flash firmware from frsky site using open-tx companion. But when I flashed non-eu firmware from frsky site by copying to sd card as explained in how to document in same site (copy bin file to FIRMWARE directory, turn on by holding trim buttons to bootloader, and choose write from the menu), I am able flash open-tx firmware using companion. I did not test by unmarking check firmware compatibility checkbox though, maybe if it is unchecked companion might updated firmware anyway.

nee helaas ook allemaal niets , denk dat ik maar even overstapt op een x4r sb inplaatst van de d4rII .

Klinkt als deze post die ik vandaag tegen kwam…

Zelf krijg ik de X4R-SB niet gekoppeld aan mijn Taranis. Weer een andere probleem.
Wat een gedoe allemaal met die verschillende soorten firmware…

Het EU non EU blijft idd lastig ja, heb nu zoiets van wil ik het wel flashen naar non EU wat wordt straks het standaard? Buiten dat vind ik het wel vreemd dat ik niet eens kan upgraden of wat dan ook.
Misschien dat er nog wat moet komen want heb de taranis + pas een klein maandje in bezit.

In principe is de LBT firmware de nieuwste. Dan moet je EN je Taranis upgraden EN je ontvanger.
D8 werkt alleen wanneer je OpenTX 2.1.7 erop hebt staan schijnbaar. Dat ga ik vanavond proberen.

weer wat dagen/weken; waar ik al zo weinig tijd in hebt, verder en een doos aspirines (voor de kopzorgen) maar de aanhouder wint, jawel het is voor elkaar de EU fimware is er eindelijk af en ik heb al ge-bind met de D4R II en met succes :clap:

alleen even geen idee nog wat nu verder te doen, moet ik ergens software/instellingen vandaan halen om te vliegen ??

Ik zou beginnen met je eens goed inlezen in je Naze32 en Cleanflight.

Veel over te vinden op youtube en het internet :




veel lezen en weinig tijd en rust om dat te doen, zachtjes aan komt het wel ja.

Pids komt wel, zorg eerst dat de basis zaken goed staan. Dus juiste quad layout ( tapblad : setup), juiste zender instellingen zodat de balkjes in cleanflight juist reageren op je sticks en switches ( tapbladen configuration en receiver) , failsafe goed instellen. Juiste modes instellen op een switch ( tapblad : modes).

thnx schiksie, balkjes reageren inderdaad nog niet op de juiste sticks dus dat ga ik maar eerst even uit zoeken

Top, welke ontvanger gebruik je en in welke modus ( ppm/pwm ? ) Heb je onder het receiver tabblad >> " channel map" de juiste selectie gemaakt ?

heb een D4R II in PPM (een brug over 3 en 4 en de naze32 aangesloten op positie 1 van de D4R)
De ‘channel map’ bij cleanflight staat op AETR 1234 en de ‘RSSI channel’ op disable , de radio setup van de taranis+ is een mode 2 en de ‘default channel order’ staat ook op AETR

Dat moet gewoon goed zijn…je weet zeker dat de mapping in je zender ook juist staat en je hebt gekozen voor een vliegtuigmodel ?

Welke stickinput krijg je dan in cleanflight op de balken ?

Roll = ?
Yaw = ?
Pitch = ?
Throttle = ?

Het Rssi kanaal heeft er niet mee te maken, die ga je straks juist wel gebruiken voor je telemetry :-). Groen en zwart aansluiten, rssi aanzetten en onder ports UART1 telemetry op FrSky zetten.