d4r-ii, x4r-sb en (EU)firmware

Ik wil voor mijn 2e quad een x4r-ii gebruiken. Hierbij staat bij MRP aangegeven dat hiervoor EU-firmware gebruikt moet worden.
De EU-firmware stond op de taranis toen ik die kreeg en had enkel -ik meen- de bindingsoptie D-16. De d4r-ii moet echter met D8 gebind geworden.

Betekend dit dus dat als ik voor de x4r-ii EU firmware nodig heb, ik geen d4r-ii tegelijkertijd kan gebruiken? Of mis ik iets?

Denk dat je de X4R-SB bedoeld ? Volgens mij kan je er ook gewoon de non eu software op zetten maar dan heb je wel weer dat tooltje nodig.


http://www.frsky-rc.com/download/view.php?sort=Firmware&down=210&file=X4R-X4RSB-CPPM-%20Non-EU%20Version

http://www.hobbyking.com/hobbyking/store/__16665__FrSky_USB_Cable.html

Of via je zender schijnt ook te kunnen :slight_smile:

D4R-II is een ontvanger die met het D8 protocol werkt, deze kan je niet binden met een taranis op EU-firmware. Als je de taranis flashed met non-EU firmware, kun je wel binden met D4R-II ontvangers, echter zullen al je andere ontvangers ook non-EU moeten zijn. Dat betekend elke X series ontvanger die je hebt flashen naar non-EU, en in de toekomst je ontvangers buiten Europa aanschaffen als je niet wilt blijven flashen.

De simpelste oplossing is een DJT module kopen voor een paar tientjes, die achterin je Taranis klikken, en je kunt binden met D4R-II, etc., alle FrSky ontvanger met het D8 protocol. Telemetrie over de externe module zal wat lastiger worden.

ah, dat verwachtte ik al. Dan ga ik me even verdiepen in het flashen!

Goed filmpje [member=315]Schiksie[/member]!

Ik heb gewoon de niet EU versie van X4R in mijn X4R zitten. Geen zin problemen met D16 en D8 mode enz. :wink:

Ik heb tot nu toe altijd met een D4R gewerkt. Mijn Taranis draait op OpenTX 2.1.6. Geen idee of dat wel of geen EU is.
De Taranis staat ingesteld op D8 en werkt met de D4R.

Nu heb ik een X4R aangeschaft (volgens mij met EU firmware, MRP), alleen nog niet in kunnen bouwen en proberen. Maar binnen de Taranis kan ik de instelling ook gewoon op D16 zetten. Dan zou dat toch gewoon meteen moeten werken met de X4R?

Nu lees ik overigens dat de nieuwe batch X4R van MRP ‘LBT’ firmware heeft?
LET OP! Nieuwe LBT (listen before talk) firmware. Verbeterde stabiliteit en bereik ten opzichte van vorige EU versies. Voldoet aan de nieuwe ETSI richtlijnen. Om te binden met deze ontvanger dient de zender ook voorzien te zijn van LBT firmware.

Zo blijven we bezig met al die firmware etc…

Mmmm ja mooi gekloot dit ;D. Maar ja als je sbus wil gebruiken moet je wel die X4R-SB hebben toch ?

Dat is wel een mooie kleine en goedkope oplossing inderdaad.

Versie OpenTX staat los van firmware in je taranis. Firmware van het zender gedeelte kan je flashen door het klepje aan de achterkant te verwijderen waar de extra zender module in kan. Via die pennetjes kan je de firmware flashen van de zender van je taranis flashen. Het is ook mogelijk om via deze pennetjes de firmware van een X4R te flashen. Om dat te doen moet je weer OpenTX tijdelijk vervangen door andere software. Ik zal vanavond ff opzoeken hoe ik dat gedaan heb.

Flashen X4R via Taranis.

Vanavond eerst maar eens opzoeken hoe ik kan terugvinden welke firmware er op staat dan… EU of non-EU.

Thanks voor de info!

Royce, als je kunt binden met een D4R-II dan heb je 99.9999% zeker non-EU firmware op je taranis staan. Dti staat los van de OpenTX versie die je draait. Ik zelf zou de X4R-SB flashen naar non-eu, en met OpenTX 2.1 kan dat via een simpel kabeltje aan je Taranis. Als je kiest voor het flashen van je Taranis naar LBT, verlies je de optie om te kunnen binden met D8 ontvangers zoals de D4R-II.

Kijk, duidelijk! :thumbup:

Ik heb inmiddels mijn x4r-sb geflashed naar non-EU. Kan alleen nog niet testen, want heb m’n fc nog niet binnen. Zeer makkelijk, firmware downloaden op de taranis, de plus/min van het bijgeleverde kabeltje van de x4r-sb omdraaien en flashen. Voila.
Althans, ik ga er nu vanuit dat het werkt :slight_smile:

douPel, je kunt ook je zender flashen met de EU-LBT zender firmware.
En ook je x4/6/8 ontvangers met de EU-LBT firmware (zit in dezelfde frsky EU-LBT.rar ingepakt).
En bij de openTX versie 2.1.x (werkt niet bij versie 2.0.x) moet je het vinkje NIET selecteren bij EU (dit vinkje staat bij de noheli, FAI, etc, in het edit settings menu van Companion).
Resultaat: als je de X4/6/8 ontvangers gebruikt (in D16) wordt in de EU-LBT mode uitgezonden.
En in D8 (bij de D4R-II ontvanger) volgens de niet EU methode.

Tnx! Ik wacht nog op m’n spullen voor de rest van mn quad, dan ga ik het verder onderzoeken.

Nou, ik krijg het niet voor elkaar om te binden met de X4R-SB

Op de Taranis heb ik D16 ingesteld en daarna voor ‘bind’ gekozen.
Op de X4R houdt ik de F/S knop ingedrukt en gooi daarna de stroom erop.
De rode en groene led blijven branden. Taranis blijft piepen in ‘bind’.
Ik heb het ook al andersom geprobeerd zoals in sommige filmpjes…
Eerst knop van RX ingedrukt houden en stroom erop. Rode en groene led blijven branden.
Daarna de ‘bind’ van de Taranis gestart. Er gebeurt niets…

Ik heb de X4R geflashed met non-EU firmware. Zijn er twee, beide geprobeerd. Zelfde effect.

Nu denk ik, ik ga de LBT firmware gewoon overal op zetten. Is hij niet meer te downloaden…
http://www.frsky-rc.com/download/view.php?sort=&down=217&file=EU%20LBT%20Firmware
Wel voor de X4R, maar niet voor de Taranis zelf…

Als ik mijn Taranis in USB modus zet, staat er bootloader 2.09. Is dat de goeie?
Ik kan nergens vinden hoe ik kan zien welke firmware er nu op de Taranis zit.
Ik kan in ieder geval kiezen voor D8 en D16. Ik heb wel OpenTX 2.17 erop staan ondertussen.

Ik heb ergens gehoord dat OpenTx 2.1.7 nog een aantal bugs bevat. Wellicht dat je 2.1.6 kunt proberen?

Je moet ook niet bij de taranis kijken, maar bij de XJT module
http://www.frsky-rc.com/download/view.php?sort=Firmware&down=232&file=Firmware-XJT
En de L9R werkt weer met deze firmware, D8 is over en uit.

notes:

XJT_LBT_build151223 integrates both D16_LBT mode and LR12 mode. For LR12 mode, just flash the firmware for XJT module, internal modules for Taranis X9D Plus and X9E, while L9R receiver does not need to be flashed. Existing L9R receivers could work with it as well.

LBT firmware is not compatible with previous EU firmware. FrSky highly suggest you to upgrade your radios, modules, receivers with old EU firmware to their corresponding LBT firmware.

Misschien ben ik nog niet goed wakker, maar dit gaat dus ook werken zonder XJT module…?
En dan vraag ik me af of hij nog gaat samenwerken met mijn D4R-II… Ik lees alleen nog maar D16 en LR12.

EDIT…
Volgens mij zit ik helemaal verkeerd te denken. Is het zo dat de X9D+ gewoon zo’n XJR module ingebouwd heeft?

Ik lees nu ook dat na installatie van de LBT firmware, D8 gewoon voor handen is, samen met OpenTX 2.1.7.

Ik vind het wel erg raar dat alle sites een link plaatsen naar een ‘lege’ downloade, FrSky zelf ook…
http://www.frsky-rc.com/BBS/viewtopic.php?f=30&t=7268&sid=b83001328b76cc8d76d809bbfcc4e342
Er staat nergens dat je die XJR firmware moet installeren.

Daarnaast zouden ook de firmware voor de X4R al in die download moeten zitten. Dat lees je overal.
Dat is ook niet het geval wanneer je de XJR-LBT download. Daar zit alleen de firmware voor de XJT in.

Echt duidelijk is het allemaal niet…

Maar dan nog zou dit niet nodig moeten zijn om mijn bind probleem met de X4R-SB op te lossen.
Ik zal er eens een apart topic voor aanmaken. Begint een op zichzelf staand probleem te worden.

Op de Taranis heb ik D16 ingesteld en daarna voor 'bind' gekozen. Op de X4R houdt ik de F/S knop ingedrukt en gooi daarna de stroom erop. De rode en groene led blijven branden. Taranis blijft piepen in 'bind'. Ik heb het ook al andersom geprobeerd zoals in sommige filmpjes.. Eerst knop van RX ingedrukt houden en stroom erop. Rode en groene led blijven branden. Daarna de 'bind' van de Taranis gestart. Er gebeurt niets..

Dat heb ik ook gedaan. Zelfde resultaat als jou. Rood en groen blijft branden. Ik heb ook bootloader 2.0.9, maar gebruik geen extra (XJT) module. Gewoon standaard Taranis Plus.

Ik wilde net gaan proberen de x4r-sb fatsoenlijk aan te sluiten op m’n naze rev5, maar bedacht me dat ik daarvoor een inverter nodig heb. Volgens Oscar z’n blog kan dat door die zelf te knutselen of op de x4r-sb zelf, zie deze link.

Ik heb alleen niet zoveel zin om aan m’n x4r-sb te gaan prutsen, aangezien ik op banggood een spracingf3 clone heb besteld en het daar gewoon op zou moeten werken.

@ Royce, jij vliegt met een naze toch? Of gebruik je een Lux? In geval van de naze: het kan niet toevallig zo zijn dat je die inverter niet hebt? Dat staat volgens mij los van het al dan niet kunnen binden, maar ik check het even (voor mezelf).

Oh, en zie net op mijn x4r-sb een sticker met “EU-LBT”. Niet dat dat nu nog wat uitmaakt verder.

[edit]

Maar dan nog zou dit niet nodig moeten zijn om mijn bind probleem met de X4R-SB op te lossen. Ik zal er eens een apart topic voor aanmaken. Begint een op zichzelf staand probleem te worden.
Hou het maar in dit topic, als je het niet erg vindt. Het gaat immers om precies hetzelfde, namelijk de d4r-ii, x4r-sb en firmware. Heb de topictitel wat aangepast.