1 motor probleem tijdens loop

Hi,

Heb een raar probleem.
Tijdens een loop vooral achter-/voorover gebeurt het soms dat mijn quad rechts achterover slaat.
Denk doordat de motor iets later start of zo? Dit zou ik met blackbox volgens mij wel uit kunnen zoeken maar die heb ik er op dit moment niet op zitten. Ook gebeurt het niet altijd dus kan er tot nu toe niet echt een vinger achter krijgen.
Weet iemand waar ik dit zou kunnen zoeken?
Setup:

  • Naze32 rev6 (weet dat iedereen er altijd allergisch voor is, maar heb tot nu toe geen problemen gezien).
  • Littlebee 20A
  • Cobra 2300Kv motoren.

Alvast bedankt,

Groeten Dick

Tja… Zonder Blackbox wordt het lastig.
Heb je toevallig een video van het probleem dan?
En geef je setup even door, inclusief CLI dump etc. Ook BlHeli settings.

Zoals je het beschrijft klinkt een beetje als een desync van de ESC. Maar dat is ook een wilde gok.
Je kunt wel herstellen nadat het gebeurt? Of komt hij in een ‘death roll’ ?

Nee heb er nog geen GoPro of DVR dus helaas geen video.
Misschien dat ik het dan ook wat beter kon analyseren.

Zal de setup vanavond doorsturen, heb die nu niet beschikbaar.

Kan de quad er nog wel uit krijgen mits ik genoeg hoogte heb.
Hij kantelt tussen de 45 en 90 graden rechts achterover en is daarna weer recht te krijgen.

Heb wel laatst mijn ESC’s gekalibreerd, en daarna in BLHeli gekeken wat de waardes waren.
De Master ESC stond iets voor of achter de andere 3 slaves. Deze heb ik toen handmatig gelijk gezet (leek me logisch als dat gelijk was :crazy: ).
Het is nu ook wel de Master ESC die moeilijk doet dus misschien dat het daar mee te maken heeft.
Als dat zo is dan snap ik niet waarom ze soms verschillen van elkaar en niet allemaal in sync zijn.

Groeten Dick

In welke mode vlieg je en maak je die loop Dick ? Geeft je blheli nog een melding zoals " “Setup not in Sync with Master” ?

Ik vlieg Acro.
BLHeli gaf die melding eerst wel na het her kalibreren via Betaflight. Maar heb toen handmatig mijn Master (de enigste die anders stond) een klik aangepast zodat ze gelijk stonden met de slaves.

Dat je ze handmatig instelt is niet erg. Als je calibreert, zijn ze inderdaad vaak niet in sync, wat ook niet erg is, eigenlijk normaal zelfs.

De versie van BlHeli kan wel van belang zijn, ook alle instellingen. De laatste versies hebben namelijk geregeld last van desyncs.
Vooral de 14.5 versie.

Ja las dat er veel problemen mee waren dus heb die op 14.4 gehouden.
Maar zal vanavond de instellingen er op zetten.

Kan me ook niet herinneren dat ik dit probleem eerder gehad heb (pas sinds gisteren).

Heb eerder wel wat dingen aangepast (pids/rates) en ook wat crashes gehad maar ja maar om dan uit te vinden waar het precies aan ligt is lastig.
Backups terug zetten van voor ik aanpassingen deed werkt ook niet omdat hij instellingen niet 100% correct terug zet.
En ik sommige dingen weer opnieuw in moet stellen naar het herstellen van een backup van Betaflight. Best irritant.

Hier een hele lijst van m’n dump.
Heb sommige dingen vervangen door … omdat daar toch niets nuttigs in stond.
Onderaan een screenshot met de BLHeli settings.


# version
# BetaFlight/NAZE 2.7.1 May 16 2016 / 20:45:45 (74cd38a)
# dump master

# mixer
mixer QUADX
mmix reset
smix reset


# feature
feature -RX_PPM
feature -VBAT
feature -INFLIGHT_ACC_CAL
feature -RX_SERIAL
feature -MOTOR_STOP
feature -SERVO_TILT
feature -SOFTSERIAL
feature -GPS
feature -FAILSAFE
feature -SONAR
feature -TELEMETRY
feature -CURRENT_METER
feature -3D
feature -RX_PARALLEL_PWM
feature -RX_MSP
feature -RSSI_ADC
feature -LED_STRIP
feature -DISPLAY
feature -ONESHOT125
feature -BLACKBOX
feature -CHANNEL_FORWARDING
feature -TRANSPONDER
feature VBAT
feature RX_SERIAL
feature SOFTSERIAL
feature FAILSAFE
feature TELEMETRY


# beeper
...


# map
map AETR1234


# serial
serial 0 1 115200 57600 0 115200
serial 1 64 115200 57600 0 115200
serial 30 32 115200 57600 0 115200
serial 31 0 115200 57600 0 115200


# led
...


# color
...

# aux
aux 0 0 0 1925 2100
aux 1 27 1 1300 1700
aux 2 0 0 900 900
aux 3 0 0 900 900
aux 4 0 0 900 900
aux 5 0 0 900 900
aux 6 0 0 900 900
aux 7 0 0 900 900
aux 8 0 0 900 900
aux 9 0 0 900 900
aux 10 0 0 900 900
aux 11 0 0 900 900
aux 12 0 0 900 900
aux 13 0 0 900 900
aux 14 0 0 900 900
aux 15 0 0 900 900
aux 16 0 0 900 900
aux 17 0 0 900 900
aux 18 0 0 900 900
aux 19 0 0 900 900

# adjrange
adjrange 0 0 0 900 900 0 0
adjrange 1 0 0 900 900 0 0
adjrange 2 0 0 900 900 0 0
adjrange 3 0 0 900 900 0 0
adjrange 4 0 0 900 900 0 0
adjrange 5 0 0 900 900 0 0
adjrange 6 0 0 900 900 0 0
adjrange 7 0 0 900 900 0 0
adjrange 8 0 0 900 900 0 0
adjrange 9 0 0 900 900 0 0
adjrange 10 0 0 900 900 0 0
adjrange 11 0 0 900 900 0 0
adjrange 12 0 0 900 900 0 0
adjrange 13 0 0 900 900 0 0
adjrange 14 0 0 900 900 0 0

# rxrange
rxrange 0 1000 2000
rxrange 1 1000 2000
rxrange 2 1000 2000
rxrange 3 1000 2000

# servo
servo 0 1000 2000 1500 45 45 100 -1
servo 1 1000 2000 1500 45 45 100 -1
servo 2 1000 2000 1500 45 45 100 -1
servo 3 1000 2000 1500 45 45 100 -1
servo 4 1000 2000 1500 45 45 100 -1
servo 5 1000 2000 1500 45 45 100 -1
servo 6 1000 2000 1500 45 45 100 -1
servo 7 1000 2000 1500 45 45 100 -1

set mid_rc = 1500
set min_check = 1100
set max_check = 1900
set rssi_channel = 0
set rssi_scale = 30
set rssi_ppm_invert = OFF
set input_filtering_mode = OFF
set rc_smoothing = OFF
set roll_yaw_cam_mix_degrees = 0
set max_aux_channels = 6
set debug_mode = NONE
set min_throttle = 1026
set max_throttle = 2000
set min_command = 1000
set servo_center_pulse = 1500
set 3d_deadband_low = 1406
set 3d_deadband_high = 1514
set 3d_neutral = 1460
set 3d_deadband_throttle = 50
set unsynced_fast_pwm = OFF
set fast_pwm_protocol = ONESHOT125
set motor_pwm_rate = 400
set servo_pwm_rate = 50
set disarm_kill_switch = ON
set gyro_cal_on_first_arm = OFF
set auto_disarm_delay = 5
set small_angle = 25
set fixedwing_althold_dir = 1
set reboot_character = 82
set serialrx_provider = SBUS
set sbus_inversion = ON
set spektrum_sat_bind = 0
set spektrum_sat_bind_autoreset = 1
set telemetry_switch = OFF
set telemetry_inversion = ON
set frsky_default_lattitude =  0.000
set frsky_default_longitude =  0.000
set frsky_coordinates_format = 0
set frsky_unit = IMPERIAL
set frsky_vfas_precision = 0
set frsky_vfas_cell_voltage = OFF
set hott_alarm_sound_interval = 5
set battery_capacity = 0
set vbat_scale = 110
set vbat_max_cell_voltage = 43
set vbat_min_cell_voltage = 33
set vbat_warning_cell_voltage = 35
set vbat_hysteresis = 1
set vbat_pid_compensation = OFF
set current_meter_scale = 400
set current_meter_offset = 0
set multiwii_current_meter_output = OFF
set current_meter_type = ADC
set align_gyro = DEFAULT
set align_acc = DEFAULT
set align_mag = DEFAULT
set align_board_roll = 0
set align_board_pitch = 0
set align_board_yaw = 0
set max_angle_inclination = 700
set gyro_lpf = OFF
set gyro_sync_denom = 4
set gyro_lowpass = 100
set moron_threshold = 32
set imu_dcm_kp = 2500
set imu_dcm_ki = 0
set alt_hold_deadband = 40
set alt_hold_fast_change = ON
set deadband = 0
set yaw_deadband = 0
set throttle_correction_value = 0
set throttle_correction_angle = 800
set yaw_control_direction = 1
set yaw_motor_direction = 1
set yaw_jump_prevention_limit = 200
set tri_unarmed_servo = ON
set servo_lowpass_freq = 400
set servo_lowpass_enable = OFF
set super_expo_factor = 30
set super_expo_factor_yaw = 30
set super_expo_yaw = OFF
set failsafe_delay = 10
set failsafe_off_delay = 200
set failsafe_throttle = 1030
set failsafe_kill_switch = OFF
set failsafe_throttle_low_delay = 100
set failsafe_procedure = ON
set rx_min_usec = 885
set rx_max_usec = 2115
set gimbal_mode = NORMAL
set acc_hardware = NONE
set acc_lpf_hz =  10.000
set accxy_deadband = 40
set accz_deadband = 40
set acc_unarmedcal = ON
set acc_trim_pitch = 0
set acc_trim_roll = 0
set baro_tab_size = 21
set baro_noise_lpf =  0.600
set baro_cf_vel =  0.985
set baro_cf_alt =  0.965
set baro_hardware = NONE
set mag_hardware = NONE
set mag_declination = 0
set pid_process_denom = 2
set blackbox_rate_num = 0
set blackbox_rate_denom = 0
set blackbox_device = SERIAL
set magzero_x = 0
set magzero_y = 0
set magzero_z = 0

# rxfail
rxfail 0 a
rxfail 1 a
rxfail 2 a
rxfail 3 a
rxfail 4 h
rxfail 5 h
rxfail 6 h
rxfail 7 h
rxfail 8 h
rxfail 9 h
rxfail 10 h
rxfail 11 h
rxfail 12 h
rxfail 13 h
rxfail 14 h
rxfail 15 h
rxfail 16 h
rxfail 17 h

# profile
profile 0
############################# PROFILE VALUES ####################################

set yaw_p_limit = 500
set dterm_lowpass = 110
set dynamic_pterm = ON
set iterm_always_reset = OFF
set iterm_reset_degrees = 200
set yaw_iterm_reset_degrees = 50
set iterm_reset_offset = 15
set yaw_lowpass = 80
set pid_controller = LUX
set p_pitch = 45
set i_pitch = 35
set d_pitch = 18
set p_roll = 45
set i_roll = 35
set d_roll = 18
set p_yaw = 90
set i_yaw = 40
set d_yaw = 0
set p_alt = 50
set i_alt = 0
set d_alt = 0
set p_level = 20
set i_level = 10
set d_level = 100
set p_vel = 120
set i_vel = 45
set d_vel = 1
rateprofile 0

# rateprofile
rateprofile 0

set rc_rate = 100
set rc_expo = 70
set rc_yaw_expo = 0
set thr_mid = 50
set thr_expo = 0
set roll_rate = 76
set pitch_rate = 76
set yaw_rate = 86
set tpa_rate = 0
set tpa_breakpoint = 1500

Begin maar eens met OneShot125 te activeren. (dat je die nog niet aan hebt staan joh!)
feature ONESHOT125

Daarna min_throttle omhoog. Die staat waarschijnlijk te laag waardoor je met Roll’s en Flips ook uit de lucht kunt vallen.
set min_throttle = 1050 (kan misschien iets lager, maar probeer eerst dit maar eens)

Min_check kan ook lager…
set min_check = 1040 (als stick commands niet werken nu, dan iets verhogen.

Aangezien in BlHeli de max_throttle wat lager dan 2000 staat, zou ik max_throttle in Betaflight op 1950 zetten
set max_throttle = 1950

Wat je ook kunt doen is in BlHeli handmatig max_throttle op 2000 zetten voor alle motoren.
Dan kun je in Betaflight max_throttle verhogen tot 1970/1980.

Het meeste effect heeft waarschijnlijk min_throttle naar 1050 zetten en max_throttle naar 1950.
Kijk maar eens of je dan nog problemen hebt. En zet OneShot aan, dat ga je voelen!!

Je Looptime draait nu op 2kHz (gyro_sync_denom = 4)… die kan op de rev6 naar 4kHz… in de GUI de Looptime op 250 zetten.
Als je dat niet doet, dan zou je nu in ieder geval de motor update naar 2kHz kunnen gooien. Is nu 1kHz (set pid_process_denom = 2)
set pid_process_denom = 1

Wow super info Royce :geek:.
Top dat je hier naar gekeken hebt :clap:.

Ga de dingen die je aangegeven hebt meteen ook wat beter uitzoeken dat ik ook een idee heb wat het betekend als ik het uitvoer in de CLI.
Oneshot hoorde ik wel een aantal keer voorbij komen maar vooral dat niemand daar echt verschil in merkte. Maar misschien dat dat over iets anders ging.

Ga dit vanavond meteen proberen 8)

Maar eigenlijk moet je over naar Betaflight 2.8.1… zeker goeie verbeteringen t.o.v. 2.7.
Gewoon de releasenote’s even doornemen, dan weet je wat er gewijzigd is.

Ja zag die ook staan maar was nog een pre-release.
Dus wist niet hoe goed deze al getest was.

Maar als dit gewoon goed is zal ik die vanavond ook meteen updaten.

2.8.1 RC1 kun je er rustig op zetten.

Heb wat dingen geprobeerd maar nu armed hij niet meer.
Denk dat het aan de min_throttle of de min_check ligt.
Deze laatste had ik al iets verhoogd maar zonder resultaat zover.

Ga nog even verder puzzelen.

Edit: Lijkt te komen door de Loop time. Als ik deze lager zet dan 500 werkt hij niet meer.

Kijk dan even in de CLI naar ‘status’… Waarschijnlijk zit je dan tegen de 100% aan. Dan armed hij inderdaad niet.
Wel raar voor een rev6 volgens mij. Bij een rev5 zou het logischer zijn.

Rev 6 zou inderdaad Accelerometer, Barometer, Magnetometer automatisch moeten uitzetten.

For Betaflight 2.4.0 onwards you should NOT use CLI but rather set looptime to 500 in the Configuration tab of the GUI. CAUTION: Appropriate sensors will automatically be disabled on F1 boards.

Op het moment dat ik hem arm zit hij rond de 60%.
Ook begint er dan een groene led te knipperen.

Edit: Groene led even opgezocht eerste wat ik tegen kwam was een failsafe.
Deze heb ik tijdelijk uitgeschakeld. Toen armde hij wel. Daarna de failsafe weer aan en armde nog steeds.
:crazy: erg raar.

Merk nu met het inpluggen van mijn batterij wel dat mijn ESC’s niet allemaal tegelijk piepen. Weet niet of dat een probleem is?
Lijkt me wel. Quad vliegt verder wel gewoon goed.

Zorg dat je de quad recht houdt bij het armen…

Als ESC’s niet tegelijk piepen, zijn ze niet in sync.
Waarschijnlijk heb je ze gekalibreerd via de Configurator?
Als je BlHeli opend, zul je zien dat max_throttle niet gelijk is bij de ESC’s.
Geen probleem verder.

Dat is dus het rare, deze staan precies gelijk voor alle ESC’s
Had deze handmatig in BLHeli allemaal gelijk gezet.

Wat ik wel merk is dat als ik de Naze al via de USB verbonden heb en dus stroom heeft hij wel goed klinkt.
Als ik die er af haal klinkt hij erg out of sync. Maar als dat verder geen probleem is is het goed.

Nu nog een probleem oplossen met mijn FPV die heeft ook besloten om te stoppen met goed werken.
Als je er eenmaal aan begint te sleutelen :o .
Het hoort er bij.